AnsweredAssumed Answered

[ERROR] repo - Manifest is bad.

Question asked by straatvark on Feb 4, 2016
Latest reply on Jul 6, 2016 by Prabath

Hi

 

I get this error when WAB start up:

 

[ERROR] repo - Manifest is bad. D:\arcgis-web-appbuilder\arcgis-web-appbuilder-1.3\client\stemapp\widgets\ImageOverlay\manifest.json

 

I dont see anything wrong in the file contents. Any advice would be much appreciated.

 

WAB and the Widget runs/works as ecpected. The messase logged is just worrying.

 

{

  "name": "ImageOverlay",

  "2D": true,

  "3D": false,

  "platform": "HTML",

  "version": "1.3",

  "wabVersion": "1.3",

  "author": "abc",

  "description": "This is the custom widget",

  "copyright": "",

  "license": "http://www.apache.org/licenses/LICENSE-2.0",

  "properties": {

    "inPanel": false,

    "hasUIFile": false,

    "supportMultiInstance": false,

  "hasLocale": false,

  "hasStyle": false,

  "hasConfig": true,

  "hasSettingPage": false,

  "hasSettingUIFile": false,

  "hasSettingLocale": false,

  "hasSettingStyle": false,

  "IsController": false

  }

}

Outcomes