AnsweredAssumed Answered

AGOL Open Data download error

Question asked by mamesser on Jan 25, 2016
Latest reply on Feb 3, 2016 by mamesser

We are having problem with the “Full Dataset” download option for certain data layers on our open data site: http://data.mtfwp.opendata.arcgis.com 

When we try to download the shapefile or the spreadsheet, the dataset gets queued, but is never returned.  A specific example currently exhibiting this behavior is our Deer/Elk hunting districts:

http://data.mtfwp.opendata.arcgis.com/datasets/38cef4e1b592416c98acc2308ed33cc3_0

 

We have tried a few methods to fix the problem. From the Open Data Management page, we’ve tried resetting the dataset and updating the index for the site, neither of which helped.  Deleting and recreating the dataset solved the problem, but only temporarily.  We recreated the dataset on Friday. Full dataset downloads worked for the remainder of the day, but are now failing once again. 

 

We had also had a separate problem with other datasets in which the Full Dataset download is partial or empty. In the case of the spreadsheet download, we’ve seen empty or partial csvs.  In the case of shapefiles, we have seen zip files that did not include shp, dbf or shx files.  We have replaced the dataset that were exhibiting this behavior, so I don’t have any current examples. 

 

We have not seen any problem with the “Filtered Dataset” downloads.

 

Any thoughts on what to do to ensure performance?

Also, does anyone know how long to the full datasets get cached on ESRI’s servers before being cleared?

Courtney Claessens

Outcomes