AnsweredAssumed Answered

Web AppBuilder - get "Failed to create the app." error on creating new app

Question asked by DSlayback on Jan 12, 2016
Latest reply on Jul 19, 2017 by jeff.pace

I've just setup a fresh install of Web AppBuilder (1.3) on a linux workstation (Ubuntu 14.04). I'm able to connect to the host's 3344 port with Chrome (version 47.0.2526.106 (64-bit)), and start Web AppBuilder, and then connect to an ArcGIS Portal account (different machine). This all appears to work fine.

 

But when I click on the "Create New" button, select default (or any other template - same result), fill in a title and description, then click OK, I get a pop-up window saying "Failed to create the app.". 

 

The console window where I launched "node server.js" shows no information from this event.

 

If I open Chrome's developer tools, it reports various syntax errors under the console tab - see attached. not sure how to interpret these...

 

I tried to do this using firefox, in case it was an issue with Chrome, but Firefox seems unable to even connect to the portal URL. Instead, on the initial page, it says "Unable to access https://<myportalurl>:7443/arcgis". Despite that very same URL working in Chrome. I've restarted node, but no matter. Perhaps that is a separate issue...or not...

 

node.js should have a sufficient version -- according to the docs, 0.10.0 required, and "node --version" reports 0.10.25 installed.

 

Any ideas or suggestions where to look for clues?

Attachments

Outcomes