AnsweredAssumed Answered

Add ESRI Premium NAIP Service to Web appbuilder dev through Arcgis Online

Question asked by Chris.JonesRoberts on Dec 29, 2015

Hello,

 

I am struggling to figure out the correct proxy settings to allow me to add Esri's premium NAIP 2014 image service to my Deployed Web app builder applicaiton.

 

current setup:

- I am using ArcGIS online

- I have the Premium service added to my content with the credentials saved with the service

- I have the .net proxy set up on my internal web server

- the web map and all of the services are set to private or shared only with my organization

- I have added services non secured services to from my server to my web map and the proxy currently passes credentials through to allow access to these services.

 

Current problem:

- Not able to successfully use ClientID and ClientSecret to authenticate against Arcgis online. I must use Username and Password in my proxy.

- Using my username and password for my online account I am able to add services hosted by my server but not ESRI premium content services.

 

I followed the instructions in the following thread to try and get the clientID and Client secret to work but i was not successful. What's the proper configuration for proxy.config and config.json for a self-hosted Web AppBuilder for ArcGIS Web Application?

 

my Config.json settings

"wabVersion": "1.3",

    "isTemplateApp": false,

    "isWebTier": false,

    "httpProxy": {

        "useProxy": true,

        "alwaysUseProxy": false,

        "url": "http://server.domain/proxy/proxy.ashx",

        "rules": [

  {"urlPrefix" : "myORG.maps.arcgis.com/",

  "proxyUrl" : "server.domain/proxy/proxy.ashx"

  }

  ]

    }

 

My current proxy settings that work for services hosted on my server and go through arcgis online

<ProxyConfig allowedReferers="*"

             mustMatch="true">

    <serverUrls>

        <serverUrl url="http://services.arcgisonline.com"

     matchAll="true"

  />

 

  <serverUrl url="http://utility.arcgis.com"

     matchAll="true"

  />

 

  <serverUrl url="http://server.domain"

     matchAll="true"

  />

 

  <serverUrl url="http://myORG.maps.arcgis.com"

     username="username"

     password="password"

     matchAll="true"

  />

 

</serverUrls>

</ProxyConfig>

 

Any Help would be much appreciated or if this question has been answered before please point me to it because I have not been able to solve this.

 

-Chris

Outcomes