AnsweredAssumed Answered

Is there an easy way to order the raster in the mosaic dataset?

Question asked by chunjie163com on Dec 24, 2015
Latest reply on Dec 24, 2015 by blake.terhune



     I assume it is quite simple, but I spent two days to search the try to find a way to do it, but I failed. So I post here to see if anyone could help.


     I have several world-view-2  images which has high resolution, and a TM image has low resolution. I looks like this after I add them in the Mosaic dataset without create the overview :




    We can see the TM image cover the world-view2 image. Of cause, when I zoom to certain scale, the world-view2 image will show.


   What I want to do is to bring the world-view2 image above the TM image, ant any scale. So I read the document and find out z-order may accomplish this, so I set the world-view2 images' zorder to -1, and TM image ZOrder to 5, as showing in the flowing image:




     Something strange happened, the TM image still covering the worldview2 Image at small extent, but When I zoom to 1:200,000, the worldview2 image displayed,but the TM image is gone. See the flowing picture:




     So I kept zoom in to 1:100,000, both images are on the screen again:




    For the scale big than 1:100,000, both Images are shown. So I think maybe it is the problem of the Mosaic Method, so I changed the Default Mosaic method from Northwest to ByAttribute, and set the order filed to "ZOrder":




    It made no difference.


    I kept searching the, and find out that I may need to increase the MaxPS value of the worldview2 image.So I set the MaxPS=[MaxPS]*4, It has an effect, now the worldview2 image can be seen at the scale of 1:800,000, exactly 4 times of 1:200,000;




     But the TM image is gone again until I zoom to 1:90,000;



   And here is the attribute table after all the value change:




   Seems I am close to the answer. The main question left is how to make the TM image and worldview2 image show at all time. Which parameter should I set? Any suggestion are welcome, thank you very much.