AnsweredAssumed Answered

ArcHydro Adjoint Catchments Issue

Question asked by pelisenby on Dec 21, 2015
Latest reply on Feb 14, 2017 by sjskhalsa

Hello,

 

I have seen several posts on a few different forums about the 'Adjoint Catchments' tool in ArcHydro running and completing successfully, but without creating any polygons, or fewer polygons than it should have created, with blank attribute tables and/or zero shape areas. As far as I can tell, there is no solution to this problem. There are only a few hints and tips that go toward hoping the problem goes away. I am posting this question here in order to hopefully add some specificity to this issue, or at least determine if the issues I am currently having are truly a lost cause. If this question has already been answered somewhere, I apologize for the duplication, but I would like to be directed to the solution.

 

I have a somewhat large data set (a 1m resolution, ~3000 km^2 catchment DEM) and I am attempting to run the 'adjoint catchments' tool. I have had no trouble in the preceding steps of running the 'fill sinks', 'flow direction', 'flow accumulation', 'stream definition', 'stream segmentation', 'catchment grid delineation', 'catchment polygon processing', and 'drainage line processing'. I currently have a catchment polygon file and a drainage line file with almost 900,000 attributes, each, and this is based on a 1km^2 river threshold used for the stream definition tool.

 

I have run the 'adjoint catchments' tool several times now with varying results. It always says it finishes successfully; however, it either creates a blank 'adjoint catchments' feature class, or one that has anywhere from 200 to 3000 polygons where some have zero shape area. Sometimes the tool only creates polygons for the northern-most catchments of my DEM (I once got it to complete ~ 70% of the catchments...until ArcGIS crashed). Invariably, the tool progress shows that in 'Pass 1' the tool evaluates about 340,000 of the 900,000 catchments; however, the Done:NotDone ratio reads as ~ 340,000:140,000.

 

I have addressed some usual suspects for this tool failure - turned background geoprocessing off, updated to the latest version of ArcHydro, cleared my temporary files, set sensible target locations, made sure my processing extent is correct. I have tried working within a save .mxd and an unsaved, untitled .mxd, along with setting different workspace processing locations. I am running ArcGIS 10.2.0 with ArcHydro ver. 10.2.0.197. I have plenty of RAM (16 GB, even though ArcGIS can only manage to use 4 GB), and plenty of free disk space.

 

The only way I have found around this issue is to go back to the 'Stream definition' tool and set a higher river threshold. I changed mine from 1 km^2 to 10 km^2. I then repeated the intermediary steps and ran the 'Adjoint catchments' tool again...and it worked fine (this time there were only ~ 44,000 catchments to process). The problem is that I need to maintain a 1 km^2 river threshold for my particular project. Does the 'Adjoint Catchments' tool have a processing limit on the number of polygons it can handle? Can I not work with more than 100,000 catchment polygons? Is there away around this apparent size limit?

 

Apologies for the long question, but I hope there is enough information here to accurately portray the issue at hand.

 

Thanks! 

Outcomes