AnsweredAssumed Answered

Raster does not display when zoomed in beyond a certain scale in a Mosaic Dataset

Question asked by joeb@cwd on Dec 14, 2015
Latest reply on Jul 10, 2020 by kaddison2

I am having a problem viewing raster images in a Mosaic Dataset I created
when I zoom in beyond a certain scale. After I zoom in past 1:3,462 ft., the
image turns black
. I have created other Mosaic Datasets of
ortho-imagery before with success, but these rasters seem to behave
differently.  These are 1 band, black and white TIFFs with a single bit
pixel depth that represent scanned base maps. (They were already geo-referenced
by a previous firm and display correctly in our old GIS). Properties lists the
format as AMD, the SourceType as Generic, the PixelType as unsigned integer,
the Pixel Depth as 1 bit, and NoData Value is blank.

When I created the Mosaic Dataset I selected Create Overlays, Statistics,
and Pyramids and I used “NearestNeighbors”. I did not input any values for
Pyramids but left the optional fields as 0 or blank so that ArcMap would
calculate the values for me. The imagery displays fine when zoomed out.

I have cleared the visible scale range.

I have checked that the TIFF displays properly when zoomed-in using Windows
Picture viewer.

I originally created the Mosaic from the set of TIFFs that were on my local
hard drive. Everything worked except the zoom. The paths to the source rasters
were intact when I exported the path list.

I then copied the TIFFs to a subfolder on the same instance of our server
that contains our SDE database and the Mosaic Dataset. I repaired the
paths so they would point to the server copy. This worked as expected but did
not fix the zoom (no change).

I then looked into the cell level values in the attribute table. For the
Primary rasters the MinPS was 0, the MaxPS was 3.004587, the LowPS was just
less than .5 and the HighPS was just less the 1. The first level Overviews
picked right up where the Primarys left off with a Min, Low and HighPS of 3.004587
and a MaxPS of around 9. These values incremented as expected into the 2nd
through 4th level Overviews. For reference I’ve attached a
screenshot of the table.

To double-check, I added the rasters to the Mosaic Dataset again from their
new location on the server in order to re-calculate the pyramids, overwriting duplicates.
This worked as expected but still displays exactly the same with no change.

I am wondering if this has to do with read access issues. I found a
reference to UNC paths by Jake Skinner in a thread regarding how to create
Mosaic Datasets: “When you zoom into a large enough scale,
the overviews are no longer used, the raw imagery is.  Also, it is best to
load your rasters into the mosaic dataset using UNC paths (i.e.
\\servername\rasters).  That way ArcGIS Server and other client machines
can access the images when zooming into a large scale.”

I’m not sure what this is distinguishing;
my pathname is \\cwdgis01\mapping\pictures\ScanBase.
The “\pictures” folder path works as it is where I store attachments for pop-up

Thanks in advance for your help!