AnsweredAssumed Answered

Drawing a enterprise geodatabase line with symbol from a related Enterprise geodatabase table not working. 

Question asked by huffmanp on Nov 30, 2015
Latest reply on Dec 8, 2015 by huffmanp

I'm still trying to get used to Enterprise geodatabase 10.3.1 based on SQL 2012 R2.  Migrated all my data over from SDE 9.3.1.  Then I thought I'd move in some data from NHDPlus so I could offer my users a few layers of streams  with line widths symbolized by average annual flow  for different scales using a relate to the NHDPlus EROM_MA0001 table.  I moved a file geodatabase containing the stream lines and table with indexes on the join items in each table over to the new enterprise geodatabase server.  Imported the feature classes and table into an existing SDE geodatabase.  The indexes seemed to be preserved in the import.  But the strange thing is that when I set up the relate between the SDE line feature class and the SDE table, then try to symbolize the line width by flow from the related table, the feature class doesn't draw.  I get a warning that sampling has reached its limit when I set up the symbology,  but I continue to manually classify the symbol ranges to spread them from minimum to maximum flow.

 

I tried some other tables and combinations of relates.  It appears that if the feature class and the table are both in the enterprise geodatabase,  nothing draws.  If either or both the feature  class and the table are the file geodatabase,  it draws as expected with graduated symbols.  Tried a feature class that is a geographically selected subset of the whole line feature class but got the same disappointing results.

 

Is the enterprise geodatabase somehow getting tangled up when both the feature class and the table are in the same geodatabase?  I thought I would be improved draw performance with the enterprise geodatabase.

Outcomes