AnsweredAssumed Answered

ArcGIS Server 10.1 Geoprocessing - PublishingTools not staring

Question asked by swexau on Nov 19, 2015
Latest reply on Jan 11, 2016 by swexau

My environment is on VM (cloud host virtual machine)

ArcGIS Server 10.1 SP1 on Windows Server 2012 R2

The registry of python path is correct (some post has solved the similar issue because the incorrect setting of python path).

 

Map Services and GP services were working find and there was no issue to publish them.

Some day, a developer tried to publish the gp services failing - no response from the ArcMap or publish through server

getting the error message :

service failed to startSystem.PublishingTools.GPServer: java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is: java.net.SocketException: Connection reset

 

Since then, repair the ArcGIS Server. restart map services is working but not able to start customize gp services. The PublishingTools is unable to start.  All get the same error message.

 

Any idea to fix this except re-install the server? Currently has 4 projects and over 80 gp services on the server?

Would it be the resource issues? The CPU may go up to 70%. ram can go up to 90 %.

Has try to search google and restart ArcGIS server or the machine. Repair ArcGIS Server sp1. checking logs for a week.

 

Once thing I noticed today, is that the publishing tool jar appears in ArcGIS /geronimo/deploy folder when i start the servies, then disappear when the ArcGIS server threw the error message.

Felt the issues may happen in connection between Internal Tomcat server and ArcGIS Server. How does tomcat server publish the service on ArcGIS server? through some sort of socket?

Outcomes