AnsweredAssumed Answered

Near analysis results in "ERROR 999999" when using a feature layer as input

Question asked by bwsparks on Oct 28, 2015
Latest reply on Oct 28, 2015 by bwsparks

Using a python script, I am running a near analysis from a small point feature class as the "in_features" to some lines (the "near_features"), a large (many thousands of records) feature layer which has a selection on it so that there are only a few records that are selected.


This script has worked for several years, but it has now stopped working, resulting in an "ERROR 999999". However, I can work around this if I add another line of code to my python script so that the small subset of selected features for my "near_features" feature layer is copied (using CopyFeatures) to a file geodatabase as a polyline feature class, and then use that feature class as the "near_features".


The help for Near Analysis says, for the near_features, that they can be "One or more feature layers or feature classes containing near feature candidates."


So why is it that this script has worked just fine using the same datasets before, but now I must save my feature layer as a feature class for it to work?