AnsweredAssumed Answered

Edit Widget in Launchpad theme not closing properly

Question asked by dbmann on Oct 27, 2015
Latest reply on Oct 27, 2015 by rscheitlin

I am using a version of the Launchpad theme and would like to use the Edit Widget, however when testing the widget acts really flaky.  The most irritating issue is that when I close the Edit Widget window it doesn't end the editing mode, ie. when I click on a feature it still brings up the editor window instead of the standard popup window. When I reopen the Edit widget window, none of my templates show up.  Also, if I open the Edit widget the first time before my editable layers are turned on, the templates will never appear in the widget after I have turned the layers on.

 

I found this post describing a different issue with the Edit widget (Edit Widget from Web AppBuilder for ArcGIS (Developer Edition) V1.2 takes the attribute from search Widget instead of it own. ) and loaded the fixed version of the Edit widget to no avail.

 

I then came across this post (Widget's callback functions in Launchpad theme not working?), leading me to believe it is an issue with the theme rather than the widget.  The onOpen and onClose functions not firing properly would seem to explain all of the issues described above.  I'm not sure exactly though how or where to implement the solution Robert proposed in that post to the Edit widget or somewhere else in the app to ensure the widget is closing properly.

 

Any help is appreciated.

Thanks!

Outcomes