MichaelSemenek

Cached map service not displaying properly in ArcGIS online web map: (Problem and Solution).

Discussion created by MichaelSemenek on Oct 22, 2015
Latest reply on Aug 22, 2017 by fernandezgis

ArcGIS Server 10.3.0 (build 4322) / ArcMap 10.3

Cached map service not displaying properly in ArcGIS online web map: (Problem and Solution).

 

Problem:

I created an ArcGIS Server cached map service and used the Tiling Scheme “Suggest” option. Set my scale levels equal to 12 or Min. cache scale of 1:500,000 to Max. cache scale of 1:250.

 

The map cache creation process in ArcGIS Server completed without any errors. The cached map service opens and displays properly in ArcMAP (Ver. 10.3). No issues / displays fast!!

 

But the cached map service will NOT display in an ArcGIS online web map…. I connected to our rest services and selected “View In: ArcGIS.com Map”. The cached map service opens in a web map, however it’s displayed as a Basemap (Not as a Content layer). Not sure why?? In an AGO web map, when you “Add / Add Layer from Web” and specify the URL to our rest service it adds the cached map service as a layer but never displays it on the map. You can see the cached map service in the Legend and Content but not on the map.

 

Solution:

When you create a cached map service. In the caching options “Cache Settings” we had to use the "ArcGIS Online / Bing Maps / Google Maps" tiling scheme. This worked... The cached map service displays properly in an AGO web map.

 

Hopefully in the near future AGO will support displaying other tiling schemes in a web map. I thought I would post this solution just in case anyone else experienced the same problem.

Outcomes