AnsweredAssumed Answered

Intermediate and output layers of GeoProcessing services are written in the wrong way

Question asked by modybsystematics-co-il-esridist Employee on Oct 21, 2015
Latest reply on Oct 22, 2015 by modybsystematics-co-il-esridist

I upgrade my server from 10.2.1 to 10.3.1 and now I cannot run any of my GP services and cannot use new ones too.

In the simplest example I created a model with buffer tool with the result defined as an output parameter.

I run the tool in ArcMap and publish it to the server.

When I run it as GP service (both from ArcMap and WAB) I get error message.

After I checked the server log and checked the server directories I found that a scratch gdb was created in  C:\arcgisserver\directories\arcgisjobs\buffer_gpserver\<SomeGUID>\scratch

This gdb cannot be accessed by ArcMap (get error) and when I use windows explorer I found the result as shape file within the scratch.gdb directory.

It looks like it creates a gdb and then use it as a simple directory and create shape file in it.

The server is sending this parameter automaticaly and it is wrong.


Is there any way around or I have to reinstall my server (and lose all my services).