AnsweredAssumed Answered

GP service ****

Question asked by on Oct 15, 2015
Latest reply on Oct 29, 2015 by

Alright after 3 days of screwing around with this I'm stumped.


Setup, ArcSDE 10.2 on Oracle 11g... Using ArcGIS desktop 10.3.1, ArcServer 10.3. on iiS.


I've registered the SDE database and a folder \\gis01\gistemp (the folder has temp.gdb and both are open to "everyone" for read/write/modify)


In Arcmap I can make a model or python script, run it and it will work locally.  However when I publish it, it says successful but doesn't write data to either of the registered databases. If I run the service from the REST endpoint, it returns no records. If I use the service as a tool , no records.


As for code: I just created a model, dropped the buffer tool on it, had it use a FC from SDE and the output to the registered FGDB. For grins, I played with the exported Python code below, changed the connection string. The Model, both versions of the connection string work well in ArcMap. and create temp fc, however as a service they run successfully but don't create anything. I closed ArcMap, to avoid schema locks but hitting the rest service endpoint returns nothing,  I've even deleted the temp fc to avoid any conflict in using the service, I've also tried this using ArcMap on the server, without luck.


Any ideas?  






# -*- coding: utf-8 -*-

# ---------------------------------------------------------------------------


# Created on: 2015-10-15 15:09:58.00000

#   (generated by ArcGIS/ModelBuilder)

# Description:

# None

# ---------------------------------------------------------------------------


# Import arcpy module

import arcpy



# Local variables:


#DOHGIS_ESRI_COUNTY_SIMPLE = "Database Connections\\dohgis@racdev (DEV).sde\\DOHGIS.ESRI_COUNTY_SIMPLE"

test = "\\\\gis01\\GISTemp\\temp.gdb\\test"


# Process: Buffer

arcpy.Buffer_analysis(DOHGIS_ESRI_COUNTY_SIMPLE, test, "300 Meters", "FULL", "ROUND", "NONE", "", "PLANAR")