AnsweredAssumed Answered

Dashed line symbology turns to white line after being selected

Question asked by paul.haakma on Oct 13, 2015
Latest reply on Oct 29, 2015 by paul.haakma

Hi All

 

I'd be interested to know if anyone can replicate this issue and/or provide feedback on why it's happening and how to stop it...

 

I have a feature service published with a dashed line symbology. I have this loaded into a map as a feature layer. When first loading the app, it displays fine. If I then select this feature, it highlights it as you would expect, but for some reason also turns the line to a solid white line. This solid white symbology then persists even after the line is unselected. Not only the selected line, but all lines with that symbology then turn to white solid line as well. At that point, I can't find any way to reset the symbology without closing and restarting the app.

 

I have tried: online/offline using GeodatabaseFeatureServiceTable vs GeodatabaseFeatureTable. Have tried saving the renderer to a json file and applying that to a renderer and assigning to the layer. Have tried reapplying that renderer after it stuffs up. None of these seem to work.

 

Any feedback or help appreciated.

 

Cheers,

-Paul

Outcomes