AnsweredAssumed Answered

Geodatabase featuredataset drawing failed

Question asked by moyooesrikr-esridist Employee on Sep 9, 2015

hi.

 

Some layers was drawing fail on enterprise geodatabase (oracle 10g R2)

 

I was able to see the records on attribute view on ArcMap 10.1.

But geometry infomation was not drawing with below message

----------

Underlying DBMS error [ORA-29902: error in executing ODCIIndexStart() routine

ORA-01006: bind variable does not exist

ORA-06512: at "SYS.DBMS_SYS_SQL", line 913

ORA-06512: at "SYS.DBMS_SQL", line 45

ORA-06512: at "SDE.SPX_UTIL", line 1480

ORA-06512: at "SDE.ST_DOMAIN_METHODS", line 139

::SELECT V__1941.st_SHAPE$, V__1941.OBJECTID, V__1941.st_points,V__1941.st_numpts,V__1941.st_entity,V__1941.st_minx,V__1941.st_miny,V__1941.st_maxx,V__1941.st_maxy,V__1941.st_minz,V__1941.st_maxz,V__1941.st_minm,V__1941.st_maxm,V__1941.st_area$,V__1941.st_len$,V__1941.st_rowid FROM (SELECT 1 st_SHAPE$ ,b.OBJECTID,b.SHAPE.points as st_points,b.SHAPE.numpts as st_numpts,b.SHAPE.entity as st_entity,b.SHAPE.minx as st_minx,b.SHAPE.miny as st_miny,b.SHAPE.maxx as st_maxx,b.SHAPE.maxy as st_maxy,b.SHAPE.minz as st_minz,b.SHAPE.maxz as st_maxz,b.SHAPE.minm as st_minm,b.SHAPE.maxm as st_maxm,b.SHAPE.area as st_area$,b.SHAPE.len as st_len$,b.rowid as st_rowid FROM WIIS.FLOWMETER_PS b WHERE SDE.ST_EnvIntersects(b.SHAPE,:1,:2,:3,:4) = 1 AND b.OBJECTID NOT IN (SELECT /*+ HASH_AJ */ SDE_DELETES_ROW_ID FROM WIIS.D1941 WHERE DELETED_AT IN (SELECT l.lineage_id FROM SDE.state_lineages l WHERE l.lineage_name = :lineage_name1 AND l.lineage_id <= :state_id1) AND SDE_STATE_ID = 0) UNION ALL SELECT 2 st_SHAPE$ ,a.OBJECTID,a.SHAPE.points as st_points,a.SHAPE.numpts as st_numpts,a.SHAPE.entity as st_entity,a.SHAPE.minx as st_minx,a.SHAPE.miny as st_miny,a.SHAPE.maxx as st_maxx,a.SHAPE.maxy as st_maxy,a.SHAPE.minz as st_minz,a.SHAPE.maxz as st_maxz,a.SHAPE.minm as st_minm,a.SHAPE.maxm as st_maxm,a.SHAPE.area as st_area$,a.SHAPE.len as st_len$,a.rowid as st_rowid FROM WIIS.A1941 a,SDE.state_lineages SL WHERE SDE.ST_EnvIntersects(a.SHAPE,:5,:6,:7,:8) = 1 AND (a.OBJECTID, a.SDE_STATE_ID) NOT IN (SELECT /*+ HASH_AJ */ SDE_DELETES_ROW_ID, SDE_STATE_ID FROM WIIS.D1941 WHERE DELETED_AT IN (SELECT l.lineage_id FROM SDE.state_lineages l WHERE l.lineage_name = :lineage_name2 AND l.lineage_id <= :state_id2) AND SDE_STATE_ID > 0) AND a.SDE_STATE_ID = SL.lineage_id AND SL.lineage_name = :lineage_name3 AND SL.lineage_id <= :state_id3) V__1941]

 

-----

 

I doubt some geography meta information of the layer, was crashed.

the number of layers with the problem is getting more.

Even not-editing layer has same problem.

 

what things do I check on the geofdatabase?

Any ideas will be helpful for me.

 

THanks.

Outcomes