AnsweredAssumed Answered

Underlying DBMS Error ORA-12154 When Connecting to Geodatabase

Question asked by pwilner_SUNYSystem on Aug 27, 2015
Latest reply on Sep 1, 2015 by pwilner_SUNYSystem

We are running Oracle 11G and Desktop 10.3.1. and Server 10.1 Server and desktop is on the same machine which is running a 64 bit Windows 7 Professional operating system, Oracle 11G is on another machine.




We originally only had desktop  connecting to our 11G database using the 32 bit client. This worked perfectly for quite some time. We were able to connect and use the databases with no problem. Recently, we decided we'd like to register our database with Server. We installed the 64 Bit Client on the machine and set the path variable to read the 64 bit client first but we are continuously getting the ORA-12154. error. We tried to connect to our Oracle database using Desktop 10.1.1 on another machine and this worked fine.


We followed the instructions here:


Register an Oracle database with ArcGIS Server—Documentation (10.3 and 10.3.1) | ArcGIS for Server


for a deployment with Server and Desktop on the same machine. However we are now finding we have no connectivity through either desktop or the server.


We are at our wits end here and would like any insight or help anyone can provide, so we're fairly certain the problem centers around the 64 bit client on the client machine.


We've seen some documentation that centers around reinstalling Desktop because the client has trouble reading from the program 86 directory because of parenthesis, but this documentation looked limited to 9.3


I'm not an oracle database expert but we have some people in the building that are fairly well versed. If anyone can provide even some insight that would be great.