AnsweredAssumed Answered

MakeFeatureLayer works in ArcMap, fails in ArcPy

Question asked by bnelson1985 on Aug 20, 2015
Latest reply on Aug 24, 2015 by bnelson1985

I have an ArcPy script that worked with ArcGIS Desktop 10.1, but after upgrading to 10.3, it fails trying to MakeFeatureLayer:  error 000732, "Dataset ... does not exist or is not supported").  I'm 100% sure the dataset exists and the path is correct.  Executing the command manually from the Python CLI results in the same error, but from within ArcMap or ArcCatalog it succeeds; I see the same behavior on several different machines.

 

Has this occurred for anyone before?  Where else can I look to determine the source of the problem?

 

PS:  Oddly enough, running the command and/or script from Python on our GP server (not ArcGIS Server; it runs regular maintenance GP tasks) does work, even though as far as I'm aware the software is set up almost identically.  Of course the server has more memory, but would that make a difference for something like creating a feature layer?

Outcomes