AnsweredAssumed Answered

Tiled Map Service not visible in WAB Layer List Widget

Question asked by Kentucky_DGI on Aug 19, 2015

We have an AGOL authored web map that includes a single tiled map service layer as one of many operational layers. There were several reasons that we decided to set it up in this manner. For many months (up until sometime in late-July we suspect) the tiled map service was visible in the Layer List widget and users could turn it on and off as needed.

 

About 2-3 weeks ago some users of this WAB created site noted that the tiled map service layer was no longer listed in the WAB Layer List Widget. The first thing we checked was the web map and it was definitely still included and in the same order as we'd remembered. No changes had been made to the web map.

 

We'd created this app using WAB 1.1 so for testing purposes, we tried it in the new 1.2 version that was released last week. Same behavior. The next thing we tried was seeing if it would list the layer in the Basic Viewer or the Simple Map Viewer that is available through the Share dialog on AGOL. It does list the tiled map service layer in both of those apps. Subsequently, I tried using the online version of WAB (rather than the on premise Developer Edition) and just like the Developer Edition, the tiled map layer was not listed.

 

We can only assume that there was a change made by Esri as there were no changes to code or the web map on our end.

 

Has anyone else seen this behavior? Is there a way to configure that widget to allow for this?

Outcomes