AnsweredAssumed Answered

NetCDF date/time interpreted incorrectly in ArcGIS

Question asked by EHan on Aug 14, 2015
Latest reply on Aug 18, 2015 by EHan

Hello All,


I try to work with temporal data stored in NetCDF format by using Multidimension Tools of ArcToolbox. Whatever NetCDF data set I use, I manage to get data into ArcGIS and work and play with it, but the date/time is interpreted incorrectly. I mean that the time values (date, time and especially the time step interval) are not correct. This makes it hard to work with certain "time slice" because it must be found by its index number instead of time value.


NetCDF files I have tried, come from reliable sources and are following the NetCDF convention "CF 1.6" which particularly should be the one that ArcGIS supports. The Panoply software from NASA shows the same data sets OK. Two of those files (and instructions as well) I tried, can be found in the Data Cookbook of NASA Goddard Earth Sciences Data and Information Services Center (GES DISC):


"How to Import Gridded Data in NetCDF Format into ArcGIS" and

"How to Define and Visualize Time Dimension in ArcGIS".


I am using ArcGIS for Desktop 10.3.1 Advanced running on Windows 7 workstation. Could this be due to my Windows locales (which are in Finnish), some ArcGIS setting, or what?


I am grateful for all solution suggestions, if any can be found.