AnsweredAssumed Answered

Accessing WMS-service with AGS 10.3.1 and external capabilities fails

Question asked by Stezii on Aug 12, 2015
Latest reply on Sep 23, 2015 by mira.valek

Dear colleagues,

 

i'm trying to publish a WMS-service on an ArcGIS Server 10.3.1 using a GetCapabilities-document from an external webserver location.

 

When I access the service via the GetCapabilities-Operation in Google Chrome a receive an error:

http://myserver.com:6080/arcgis/services/folder/serviceName/MapServer/WMSServer?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities

error on line 2 at column 1: Extra content at the end of the document

Sometimes, the Capabilities-document shows up (5 % of all requests after refreshing), but this can't be reproduced explicitly. Thus, embedding the service into a client like ArcGIS Desktop fails.

Publishing the service with internal/default capabilities returns a HTTP 400.

 

Accessing the Esri MapService works.

The error occurs in every version of the capabilties document.

I also managed to publish the same service on a 10.1 and 10.3.0 machine with internal and external capabilities succesfully.

 

It would be great if s. o. has an idea how to solve this problem.

 

Thank you!

Stezi

Outcomes