AnsweredAssumed Answered

do you have working relationship classes in Server?

Question asked by imgooch on Jun 29, 2015
Latest reply on Jan 11, 2016 by russell_roberts-esristaff

So I've been working with ESRI tech support regarding issues with relationship classes in Server, and in ArcMap for that matter and they ultimately said they reproduced the issue and logged bugs, but if that is the case then that means that no one out there has a working relationship class and I find that hard to believe.  So I'm here to see if others have the same issues or not.

 

I am using 10.3.1 versions of ArcMap and Server and my data is in a SQL Server Express EGDB.

 

I have a feature class, a table and they are related via a 1-M relationship class.  I have a feature service with these layers included.  I need to be able to add related records (inspection reports) to the feature class via Collector, which is connected to Portal.  I also want to be able to do this through my Flex application.

 

If I create the relationship class WITHOUT attribution:

  • In ArcMap:  When I attempt to add a related record to a feature (in edit session using "add new" within the attributes window), it appears as if nothing happens.  However, I found that it is adding the related record with the default field values, but not putting any reference to in the relationship class table and is therefore not related to the feature.
  • In Flex:   I had the same result as in ArcMap.  Related record gets created but not the entry in the relationship class.
  • In Collector:  When attempting to add a related record, it appears to be trying to add a new entry in the relationship class alone.  The fields it prompts for are "ORIGINFOREIGNKEY" and "DESTFOREIGNKEY", but not for the fields I have in the related table.
  • In ArcMap via feature service:  If I bring the feature service into ArcMap, I have the same result as in Flex and when accessing the data directly in ArcMap.

 

If I create the relationship class WITH attribution:

  • In ArcMap:  Everything works as expected.  Related records are created and are correctly referenced in the relationship class so they can be seen attached to the feature.
  • In Flex, Collector and feature service in ArcMap:  Related records are added to the table, but are NOT referenced in the relationship class and are therefore not related at all.
  • I also tried adding the feature service to AGO and connecting Collector to that.  Same result.  However, a hosted feature service works as expected.

 

So my question to everyone is, do you have working relationship classes at all?  In desktop or Server?  I'm fairly certain the answer is yes but need to ask!  If so, what configuration do you have that differs from my own?

 

I find it hard to believe that this is a bug since it would mean no relationship classes for anyone, but this is what I've been told and am stuck.

 

Any thoughts on what the issue could be?

 

Thanks!

Outcomes