AnsweredAssumed Answered

Trying to get a date field to have no value.... Somehow destroyed all my data...

Question asked by AaronCraig on Jun 27, 2015
Latest reply on Jun 27, 2015 by AaronCraig

Ok...... What happened..?

 

I have a feature service layer in ArcGIS online that has a date field.

 

I run FME to insert new records. FME sets the date to null before inserting. And resets existing records dates as null then updates them. FME does exactly what it is supposed to do.

 

The problem is how AGOL handles null dates? It can have new records with blank dates, but null seems to be a problem, and I am not sure how to push up blank dates (possibly by using missing or empty, I will test later).

 

All these new and updated records all have dates now that are 1/1/1900.

 

I do not want a value in these date fields because it represents when something is complete, and to have it pre populated with an incorrect hundred year old date is unprofessional.

 

So I tried calculating it to null in AGOL using null, single quote single quote, None, etc.. Nothing was successful.

 

Then I tried in ArcGIS pro using null, single quote single quote with no success.

 

Tried calculating None into the date field, and it worked, but deleted ALL my attribute data. What happened here??

 

Edit: It appears that any calculation I make in ArcGIS pro deletes all the other data in the other fields??!? :-/ Am I using calculate wrong in ArcGIS pro???

 

Message was edited by: Aaron Craig

Outcomes