AnsweredAssumed Answered

Precision Issues in Reclassify

Question asked by wrights16 on Jun 22, 2015
Latest reply on Jun 22, 2015 by wrights16

Hi,

 

I'm having some trouble with precision in Reclassify and was wondering if anyone has any insight or advice for reclassifying using new values with decimal places. I tried assigning unique Old Values that were in LONG data type to values of 1.5. Every time I tried to do this, it assigns these to 1 and nothing I change precision option seem to modify this.

 

Then I thought about it not working because the Old Value data type was LONG. I created a new field with the same values but changed the data type to FLOAT. So my new "Old Value" input in the Reclassify tool is in the FLOAT format. I put in the new values, using proper hyphens for the ranges (unique is not an option for FLOAT) and it's still rounding my 1.5 to 1. Making changes within the precision option in the tool, again, is not modifying anything at all.

 

Has anyone had problems with just the precision option not modifying the new values? Or can I not reclassify my data with a fractional number at all?

 

Thanks!

Samantha

Outcomes