AnsweredAssumed Answered

Apparent Reflectance Function not working

Question asked by mschau5 on Jun 17, 2015
Latest reply on Jun 17, 2015 by Dan_Patterson

I am trying to use the Apparent Reflectance Function in ArcGIS 10.2.2 for Landsat 8 data in order to see Albedo. I have the metadata file with the REFLECTANCE_MULT and REFLECTANCE_ADD values standing in for Gain/Bias (because that is what Landsat 8 uses as stand-ins for gain bias) and with the Sun Elevation but the values are not populating in the function and when I enter them manually I get:

"The function could not be inserted. The input or output arguments are invalid."

At first I tried it on a tif file with more than 13 characters so i converted it to a float type with far less than 13 characters but got the same result. I'm using 10.2.2 and have already got the Landsat 8 patch.

If this function is bunked, is there a simpler way to do it in Python?

 

The links to the tool:

Apparent Reflectance Raster Function | ArcGIS Blog

ArcGIS Help (10.2, 10.2.1, and 10.2.2)

 

Any ideas?

Outcomes