AnsweredAssumed Answered

Problem with replica creation and synhronization of changes

Question asked by milica_esri on Jun 10, 2015
Latest reply on Jun 10, 2015 by jskinner-esristaff

hello,

 

I have two databases that I am dealing with. Both are Postgres(postgis) db on Posrgresql 8.3 server. I am accessing them through ArcSDE 10, and for all operations that I am performing I use ArcGIS(Map or Catalog). One of db is main db for which we are doing editing, adding new data etc. Another db is using for publication purposes, it is read-only db. Till one week ago everything was ok, we have had one-way replica created between databases, and after some new records or editing of existing we compressed main db and synchronize changes between databases.

 

But right now it does not work. Changes in main db can not apply to replica db. When I access main db through PgAdmin I can see new or deleted features in a and d tables, and after compression it is stored in base tables (that is OK). But after that when I do synchronization (connected) of changes with previously created replica, changes do not applied to replica db (it look like synchronization process starts, but is last very short and there is no changes inside of replica db).

I tried to create new replica, but it did not succeed. The error message is always like this:

I have tried to create new replica for existing databases and also i tried it with other(new/old) databases on the same server, but it is always without success. All datasets are versioned and Global ID are created.

 

If you have any idea or solution please post it.

Outcomes