KG22

Long running gp task sort of fails

Discussion created by KG22 on Oct 25, 2010
Latest reply on Feb 24, 2012 by Dalshearer
I have a long running gp task that is a python script exposed by as a gp tool over the js api.
When i execute the task it returns a dojo.io.script error saying the Timeout exceeded. However a few seconds later it does return the correct result.
Something on the server I think is causing the timeout error message to be returned which is firing the errcallback on the method call, instead of waiting for the true result to fire my callback method.
I have tried to modify the timeout settings in IIS, web.config, and web.config in the rest services config. I also bumped the server object idle times, tried both pooled and non-pooled and synchronous/asynch on the server object.
If I could just ignore the err callback and get the method to fire when the result came back i would be set but if i comment out the err callback the true callback never gets hit.
Is there some magical one minute setting in IIS or ags?
Any suggestions?

Outcomes