AnsweredAssumed Answered

Reclassify Tool: unexpected behavior / bug

Question asked by lhamann on Apr 22, 2015
Latest reply on Jul 28, 2016 by BucknellGIS_LY

In certain cases, the Reclassify Tool (Spatial Analyst) generates wrong results: The number of classes generated for the output layer (specified by the Attribute Table) deviates from the custom n.o. classes. However, the preview table presented in the Tool Pane is always correct.

 

Obviously, the problem occurs mainly when Reclassify is applied on 64bit dataset, potentially when it's minimum value is below a certain value. therefore the following indicators:

 

- problem rarely occurs with Input data of 32 bit.

- problem occured first on a Raster (TIFF, 64 bit, double precision) with value range [0.4, 19]. With a custom n.o. classes > 19, Reclassify worked correct.

- After multiplying the same raster with 100, Reclassify worked correct. The value range was now [40, 1900], dataset format / type was the same.

- At a DEM dataset (TIFF, 64 bit, double precision) with value range [1080, 4000], Reclassify worked correct.

- After subtracting 1080 from this Raster (--> value range [0, 2920]), the problem ocurred again

- The original DEM Raster [1080, 4000] converted to 32 bit (Esri Grid format) was correctly reclassified for n.o. classes <= 25. With n.o. classes > 25, the problem ocurred again.

 

Supplement: after reporting the problem to Esri Support, the behavior was reproduced and is addressed to be solved (2015-04-24).

Outcomes