AnsweredAssumed Answered

ERROR 000732 View does not exist or unsupported after 10.3 upgrade

Question asked by Colli on Apr 17, 2015
Latest reply on Jan 29, 2016 by tselvidge

We have a few models that update a point and polygon feature class in our DB a few times a day using a view into our projects DB. We have exported this to py and made a small change "arcpy.env.overwriteOutput = True" and set to run using windows task manager. All good until we moved our beta to 10.3 earlier this week. I realized after a few days that the script was failing in task manager.

 

I ran the script in Idle to see if I could trace the problem. Viola... this is what we see.

 

ExecuteError: Failed to execute. Parameters are not valid.

ERROR 000732: XY Table: Dataset Database Connections\inserrtservername.sde\EBISDE.dbo.project_tel_new_vw does not exist or is not supported

Failed to execute (MakeXYEventLayer).

 

The view works. I return records when I view in SSMS and Catalog. The model works, and writes new features to the features in the DB. I even deleted my DB connection in catalog, made a new one. Opened the models and re-pointed the GP tools to the view and features hoping this would clear up any mis-matched connection names etc. and export to python. 

 

What happened at 10.3 that python is unable to make the DB connection? Seems straight forward, but I'm stumped.

 

 

Outcomes