AnsweredAssumed Answered

Error upon trying to deploy workflow manager system?

Question asked by esrikw_falcon on Apr 8, 2015
Latest reply on Apr 15, 2016 by apurv.danke

Hi All,


I am trying to setup a workflow manager environment in our office for better work management. I am stuck at a point of deploying Workflow manager on client machine. Below are the steps I have followed along with the description of the issue I am facing:



ArcGIS Desktop 10.3

ArcGIS Workflow Manager 10.3

SQL Server 2012


1. Created 2 geodatabases on SQL Server instance - both DBO schema, one holds the data (PROD_DB) while the other one holds the workflow manager repository tables (WFM_PROD_DB)


2. Ran Workflow manager post-installation with 'Quick Configuration' on WFM_PROD_DB


3. Created new workflow, created new job, associated job with the workflow, added map document and workspace to the job.


3. Created  2 SQL authenticated logins on the SQL Server instance and mapped them with the geodatabases above


4. Granted them SELECT on both the geodatabases and granted dataset level permissions from ArcCatalog on the data in PROD_DB so that they can edit the data


5. Created 2 users in workflow manager corresponding to above two database users and assigned them 'Technicians' group.


Everything went fine till this point. Problem occurred upon trying to deploy this on client machine,


6. Installed ArcGIS Desktop 10.3 and ArcGIS Workflow Manager 10.3 on 2 machines


7. Tried opening 'Workflow Manager' received following error:




which was expected as I had not configured a database connection yet.


8. So, followed steps mentioned in following link to configure the connection:

At this step, first part of 'Add Workflow Manager connection' goes through without any errors.


Second part,  'Workspace properties' also goes through without any errors.


Here in connection properties, credentials of above mentioned database users were provided.


After this when tried connecting to the new Workflow Manager Database node that was created, I received following error:




Here is what I have tried or checked:


1. Granted SELECT, INSERT,UPDATE,DELETE explicitly on the tables in the error message to these users - Did not help


2. Granted SELECT, INSERT,UPDATE,DELETE on WFM database (WFM_PROD_DB)  to these users - Did not help


3. In SQL Server ran queries against the tables in error message by connecting as problematic users and the queries returned results.


4. Created connection to WFM database (WFM_PROD_DB) from ArcCatalog with above mentioned users and checked if they can view the tables in the error message and they could.


I am not sure if I am missing something or doing something incorrectly. Any help would be much appreciated.