AnsweredAssumed Answered

Dissolve not working in Python Script

Question asked by ldcarto on Apr 1, 2015
Latest reply on Apr 1, 2015 by ldcarto



I run nightly updates on many datasets and have completed dissolves for a few years and they used to work just fine.  Now, for some reason I cannot get any of the dissolve models to work when triggered from the python script.  The models work when I run them manually through ArcCatalog, but I need them to work through the python script every night as opposed to having to run them manually every morning.

I have added a Repair Geometry tool into the model to take care of any issues there, but I still get the invalid topology error (but I only get this error when it runs through Python).  I have exported the model into a python script and copied and pasted that into the nightly update python script, and that didn't help either.  I have tried many options like creating new models, creating new geodatabases or shapefiles and it still will not work through the python script.

This seems to have started after I tried to run a dissolve on a rather large dataset which took over two week to process in ArcMap and it still hadn't completed when I cancelled the process.  Ever since then, any models including a dissolve command have not work through python.  I have rebooted my computer several times, and it is still a problem.

I am using ArcGIS 10.2.1 (I cannot upgrade easily because I do not have admin rights) on Windows 7.


If anyone has any ideas or suggestions of what I can do to get the dissolve to work again, I would greatly appreciate it.  Because I do not have admin rights, I am limited as to what I can try without having to put in a request to our IT department (which can be a long, painful, and frustrating process).


Thanks in advance for any assistance.