DrColgate

Assign HydroID "Invalid procedure call or argument"

Discussion created by DrColgate on Sep 22, 2010
Latest reply on Sep 29, 2010 by DrColgate
I am having trouble using the Arc Hydro Tools 'Assign HydroID' function.  I consistantly get a "Invalid procedure call or argument" error when I attempt to run it.  When I press OK on this error message the Assign HydroID window appears but has no Map or Workspace data.  The Layer list is populated with a single layer that does not exist in my MXD called either lboLayers or IboLayers.  I cannot tell which due to the font.  Selecting this layer results in a '91 Object variable or With block variable not set' error.

I have tried the tool under ArcView, ArcEditor and ArcInfo licenses though I understand this is not required for Assign HydroID.  It seems as if the rest of the tools are working but I cannot be sure as I am not familiar with them as yet.  At least when I select other tools the layers that exist in the MXD are populated correctly.

I have tried using Feature Classes from File Geodatabases as well as shapefiles though neither show up.  I have also tried numerous versions of the associated files (ArcHydro Tools including the beta version, APFramework, Geo-RAS etc) either with the same result or further errors when there is a mismatch in functionality between the support files.  It should be noted this error is different to the '5, Invalid procedure call or argument' I was receiving before installing APFramework, GeoRAS etc.

At present I am using the Arc Hydro tools for 9.2-9.3 Version 1.3 (01162009), APFramework (03102009) GeoRAS (042109) and XMLDataExchange (Z011508).  This is used with ArcMap 9.2 (Build 1500).

Outcomes