AnsweredAssumed Answered

Feature Dataset mixed versioned and non-versioned data - cannot edit

Question asked by karamichalke on Mar 24, 2015
Latest reply on Dec 31, 2015 by MFarretta-esristaff

I am trying to fix a feature dataset in our ArcSDE geodatabase which we are currently completely unable to edit. The feature classes within it are a mix of versioned and non-versioned feature classes and the dataset does not participate in a topology or a geometric network. I have tried to register the entire dataset as versioned; however, I get this message when I do:

If I select "OK", all of the tables are still not registered as versioned. When I go to edit, each feature class has two errors listed which are "Layer or table is not registered as versioned" and "Incorrect edit version type".

At this point I don't know if I need to export all of my feature classes out and then re-import them so I can register them all as versioned or if there is another way to fix this. Any help would be greatly appreciated!

Outcomes