AnsweredAssumed Answered

Using Export Tile Cache in scheduled job has rights issues

Question asked by dougbrowning on Mar 23, 2015
Latest reply on Mar 23, 2015 by dougbrowning

I am running this command in a python script

arcpy.ExportTileCache_management(unzipedTPK, pathTPK, justfilenameTPK, "TILE_PACKAGE", "#", "#", boundryFile)

 

It works fine if I run it in PyScripter.  It also runs fine if I run it from a batch file. 

 

But if I schedule that batch file with Task Scheduler it dies with this error.

ExecuteError: ERROR 001132: Failed to export cache

ERROR 001485: Failed to create tile package : \\hnrgad\vancouver\GISFiles\Projects\MobileMap Data\CurrentBuilds\BC\TPK\BCSettings.tpk

Failed to execute (ExportTileCache).

 

I found old bugs that it does not pick of the user correctly but nothing that is recent.  It seems to die on trying to create a subdir.  It will create the main names dir and conf.cdi, conf.properties, and conf.xml but not anything else.  The task seems fine and has rights in every other part of the script (runs Create Tile Package to same location fine).

 

The user is in the Admin group.

 

Any ideas?

 

10.3, Windows 7 Enterprise

Thanks

Outcomes