AnsweredAssumed Answered

Using definition queries, joins, labelling in Map document launched by WMX

Question asked by alison_ott on Mar 9, 2015
Latest reply on Mar 13, 2015 by alison_ott

In our workflows one of our key steps is the Launch of ArcMap to open a custom map document.

 

We are having a number of problems with these documents and would like to understand if others are seeing the same or if we are alone in our adventure. This is all being done in version 10.2.2.

 

Using the Add Data button from the WMX toolbar, our map documents include the following:

  1. Linear feature class from an Oracle SDE database that has the following
    1. Five related tables (using relationship classes)
    2. One join a table based on a unique field (the joined table participates in one of the relationship classes in "a")
    3. Features are labelled by a field from the joined table
    4. Symbolized by a unique value from the feature class
    5. Only a subset of fields have been defined as visible.
    6. One field is highlighted
    7. Definition query (using values from the joined table)
  2. Explicitly added the related table used for the join into the .mxd
  3. Polygon feature class from an Oracle SDE database that has the following
    1. Features are labelled by a field on the feature class
    2. Only a subset of fields have been defined as visible.
    3. One field is highlighted\

 

When the map document is opened as part of the LaunchArcMap step, the following items do NOT work properly

  1. Linear feature class from an Oracle SDE database that has the following - owned by the step owner
    1. Five related tables (using relationship classes) - show and are owned by the step owner
    2. One join based on a unique field - Still owned by the user that created the map document (known issue - NIM095174)
    3. Features are labelled by a field on the feature class - Labelled instead by the primary key field of the feature class
    4. Symbolized by a unique value - works
    5. Only a subset of fields have been defined as visible.- All fields are visible
    6. One field is highlighted - No field is highlighted.
    7. Definition query - works
  2. Explicitly added the related table used for the join - owned by the step owner
  3. Polygon feature class -  owned by the step owner
    1. Features are labelled by a field on the feature class - works
    2. Only a subset of fields have been defined as visible - works
    3. One field is highlighted - works

 

We have tried using the Add Data button from the standard toolbar, but does not work well for switching users.

 

Anyone else using complicated map documents? Any suggestions of rules to follow? When to use WMX add data? When to use ArcMap Add Data? Any advice would be appreciated, including if this has changed at 10.3.

 

Thanks,

     Alison

Outcomes