AnsweredAssumed Answered

Connecting to ArcGIS Server after configuring SAML and Federating

Question asked by cadamsesriuk-esridist Employee on Feb 20, 2015
Latest reply on Jun 4, 2018 by Szymon.Piskula_WoodMacOnline

After setting up Portal for ArcGIS 10.3 to use SAML with AD users, we are unable to create an ArcGIS Server connection in ArcMap. Has anyone else come across this?! All other admin functions work; we can sign in to ArcGIS Server Manager with our AD credentials, we can log in to Portal fine. I tried creating a token directly but this fails as well:

 

https://<machine name.domain>/arcgis/sharing/generateToken

 

"Invalid username or password"

 

I am definitely not entering an incorrect username or password, unless the username format is wrong. I have tried:

 

DOMAIN\username

domain\username

username

portal username

 

The token is only generated successfully for the initial admin account.

 

I can log in to the the portaladmin site and search on enterprise users. Correctly, my username shows up but for some reason, ArcGIS Desktop is not authenticating AD users. It does authenticate against the initial admin account absolutely fine.

 

Authentication worked fine before using SAML, i.e, using AD users and federating with Server.

Outcomes