AnsweredAssumed Answered

Strange behaviour with "Locate Features Along Routes"

Question asked by HavardMoe on Feb 19, 2015
Latest reply on Mar 6, 2015 by HavardMoe

I'm having some strange behaviour with the "Locate Features Along Routes" function with ArcGIS 10.1.

 

I have:

  • One feature class with line geometry with an attribute I want to create linear events from.
  • 45 feature classes with the defined routes

 

I want:

  • Event tables per route

 

To create my events I iterate over the routes and create one event table per route, using the arcpy.LocateFeaturesAlongRoutes_lr() function.

 

My initial test on a couple of the routes worked fine, but when I attempt to run though all of them I get this:

 

Executing: LocateFeaturesAlongRoutes C:\Work\FGDB.gdb\Features C:\Work\FGDB.gdb\Route1 RID "1 Meters" C:\Work\FGDB.gdb\EventTable "RID LINE FromM ToM" FIRST DISTANCE ZERO FIELDS M_DIRECTON

Start Time: Thu Feb 19 14:41:01 2015

ERROR 999999: Error executing function.

The table was not found. [EventTable]

Failed to execute (LocateFeaturesAlongRoutes).

Failed at Thu Feb 19 14:41:02 2015 (Elapsed Time: 1,00 seconds)

 

I run through the database (just added some exception handling to list the ones with errors) and find that 16 out of the 45 routes give this error, while the rest go through ok.

 

I wondered if it could be my script, but the same routes fail when I use the tool in ArcMap.

 

I've checked the input data, and can't really find what the issue is with the 16 problem routes. Some of them are short and easy (one feature), others of them are longer and more complex. All of the routes have measures set, with nothing particular shoving up using the Route Measure Anomalies display.

 

Anyone else seen something like this?

Outcomes