AnsweredAssumed Answered

Managing attribute domains that have schema locks

Question asked by johnsb2 on Feb 13, 2015
Latest reply on Mar 16, 2017 by Alexander_Brown-esristaff

We have an attribute domain that will need to be updated on a regular basis as new values are added to a master table of street names, and we are trying to find a way to script out the updating of it. Now the issue is this domain is assigned to fields in several feature classes that will almost always have schema locks on them from users leaving ArcMap documents open and some map services.


We have tried several versions of a workflow in our Python script; but it always ends up reporting the same error at some point:

ERROR 000464: Cannot get exclusive schema lock.  Either being edited or in use by another application.


  • Our first attempt was to simply use the Table to Domain tool to overwrite the existing domain values; but that crashes due to the error.
  • Secondly, we tried to first remove the domain from the pertinent feature class fields, then use Table to Domain to replace the domain values; but the script throws the error when trying to reassign the domain to the needed fields.
  • Our other possibility was to generate a list of all the current domain values, delete those values from the domain, and then append in the new values with Table to Domain (thinking that maybe appending instead of overwriting on the domain would solve it); but the error appears here when trying to delete the existing values from the domain.

When our nightly update scripts run there will almost always be some schema locks on that domain; so we need to find a way to update the domain with those present if possible.


Wondering if anyone has run into a similar issue and found a workflow that gets around those pesky schema locks?



GIS Technician

City of Auburn, AL