AnsweredAssumed Answered

Synchronizing ArcMap Desktop edits back to AGOL

Question asked by darmynelson on Jan 22, 2015
Latest reply on Feb 4, 2015 by boston1685

On a number of hosted feature services I have successfully "Created Local Copy", "Start Editing", make edits and "Synchronize Local Edits with Server". This time though, is different. When I try to sync the edits back I get this message:



When I first rec'd this message I tried the workflow out with another Feature Service and it worked swimmingly.


There is one difference to the edits I have made to this service, probably the culprit, but I thought I would ask anyhow. Adding a Field. I noticed that the process is a little different than regular Desktop edits to a local feature. In Desktop, you cannot be in "Editing" mode to add a field. With a local copy from a hosted feature service, you must be in "Editing" mode to add a field. My initial guess is that this is where the problem is. For those who will ask this is the workflow I have used:

add my FS from AGOL to Desktop blank map, zoom to extents (as to incorporate the entire FS for edits), right-click group name -->edit features-->create local copy (works fine), right-click feature-->start editing-->add fields-->create join-->calculate fields(some are distance calculations, others are just copying over other fields i.e. = another field from join)-->remove join-->save edits-->stop editing, right-click group name-->edit features-->Synchronize Local Edits with Server-->error message from above-->head banging against desk!!!


Assuming that since the ability of "Add Field" is an option it should work, what am I doing wrong? Any advice or suggestions would be helpful, I do not want to export to .shp, delete feature service, publish new service, update all AGOL maps if I don't need to, thanks!