AnsweredAssumed Answered

Error thrown from Toolkit after upgrade to VS Update 4

Question asked by sfisher on Dec 3, 2014
Latest reply on Dec 10, 2014 by akajanus-esristaff

A colleague of mine upgraded his Visual Studio 2013 to Update 4 and now gets the error below thrown from the ArcGIS Runtime Toolkit for .Net.  Others on the team, including myself do not get this error staying at VS Update 3.  We also tested on another VM with update 4 and same error occurs, so we are guessing its something related to Update 4. 

 

Anyone get this issue? Or have any suggestions? Besides reverting to Update 3, he already tried and cannot seem to do that.

 

 

Error is thrown in ScaleLines.cs GetMile method.

 

Inner Exception:

{"Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))"}

 

  1. System.TypeLoadException

{"Requested Windows Runtime type 'RuntimeCoreNet.CoreUnit' is not registered.":"RuntimeCoreNet.CoreUnit"}

 

Stack Trace

   at System.StubHelpers.StubHelpers.GetWinRTFactoryObject(IntPtr pCPCMD)

   at RuntimeCoreNet.CoreUnit.Create(Int32 id)

   at Esri.ArcGISRuntime.Geometry.Unit.TryCreate(Int32 id)

   at Esri.ArcGISRuntime.Geometry.Unit.Create(Int32 id)

   at Esri.ArcGISRuntime.Geometry.LinearUnits.get_Inches()

   at Esri.ArcGISRuntime.Toolkit.Controls.ScaleLine.GetMile()

   at Esri.ArcGISRuntime.Toolkit.Controls.ScaleLine.Refresh()

   at Esri.ArcGISRuntime.Toolkit.Controls.ScaleLine.OnScalePropertyChanged(DependencyObject d, DependencyPropertyChangedEventArgs e)

 

Outcomes