AnsweredAssumed Answered

Unable to publish a Referenced Mosaic Dataset to ArcGIS Server 10.2.1

Question asked by dan_h_b on Dec 3, 2014
Latest reply on Dec 4, 2014 by jskinner-esristaff

I have a number of Raster Catalogs I want to publish. It is my understanding that in order for them to be published to ArcGIS Server I need to create Referenced Mosaic Datasets for them.

 

I have done this.

 

I have also successfully registered the data folders with ArcGIS Server and enabled the Image extension (this is needed to publish mosaics).

 

When I come to publish the referenced mosaic dataset, in the Service Editor I select to only use the “Image” capability and for it to only allow the “image” operation, as I only want the user to be able to view the data. I am not caching the service.

 

When I analyse the service, I only get one Medium error. This is just warning me that no statistics have been calculated for the Mosaic dataset. As this service is a “view-only” service, I do not need statistics.

 

When I click on “Publish”, it runs through the whole publishing service and then I get an error

Failed to Publish Service.

If I look at the server log, I see the following error:

Error executing tool.: ERROR 001369: Failed to create the service. Failed to execute (Publish Service Definition)

This seems to be a generic error.

 

Digging a bit more into the server log I can see that there is an error about an invalid path:

Invalid input data source path: \\servername\data\Production\Backdrop_Mapping\Mosaics\Data_50K\Data_50K.gdb\Data_50K

This is referring to the Mosaic dataset which I am trying to publish.

 

This folder is successfully registered as a data store on the server:

\\servername\data\Production\Backdrop_Mapping

As I understand it, this should include all subfolders.

 

In order to test this, I have created a simple mxd with 1 vector dataset and published it from the same source folder without any problems. The vector dataset was in the same fgdb as the mosaic dataset. So I know the server is able to connect to and read from this location.

 

Any suggestions of what I could try next would be great.

 

Many thanks.

 

Tech spec: ArcGIS Sever 10.2.1, Standard Licence, Image extension.

Outcomes