AnsweredAssumed Answered

Trouble adding an onsite feature services in ArcGIS.COM map

Question asked by VApteesriaustralia-com-au-esridist Employee on Nov 12, 2014
Latest reply on Oct 27, 2015 by shaunrconway

Hi,

 

I am having a little issue in configuring AGOL map to be used in ArcGIS Collector app.

 

The map will have base map from AGOL and an editable feature service that is hosted on client’s own ArcGIS Server 10.2.2. This ArcGIS Server is externally available through Microsoft ISA Reverse Proxy with Web Adaptor and ArcGIS Server sitting behind the firewall. Web Adaptor in IIS is set-up as Windows Authentication. The external URL is accessed using https protocol. Web Adaptor and ArcGIS server are also configured in https-only mode. ArcGIS Server security is configured in Windows Tier mode. The service I am testing is not secured at this time but eventually it will be.

 

I can edit feature service data externally over REST API . Also add feature service to ArcMap running outside of the client's network, edit the data and sync it back. So it proves the set-up is correct.

 

However, when I add this feature service to AGOL map, AGOL sends warning saying

 

Layers
-  Collector_Trial_Dataset.Drainage

-  Collector_Trial_Dataset.WaterBody

seem to be on an internal network and are not accessible to ArcGIS.com. Thus, editing will be disabled on these layers.

 

However, AGOL shows the data in the map and I can identify/query it. So what causes AGOL to infer this feature service is on internal network?

 

If I turn https to http all along and also set-up Web Adaptor in IIS to use anonymous authentication instead of Windows Authentication, editing works in AGOL.

 

I have seen this thread below but I have also seen presentations that say Collector can consume secured feature services.

How to edit SDE layers

 

Any help to resolve this issue is greatly appreciated.

 

Cheers,

Vish

Outcomes