AnsweredAssumed Answered

Entire directory of shapefiles suddenly unopenable

Question asked by nrp1000 on Nov 3, 2014
Latest reply on Nov 3, 2014 by nrp1000

I've run into a strange problem with all of the shapefiles in a particular directory. Last week, I was able to access the files with no issues. This week, I tried adding one of the shapefiles in ArcGIS 10.2.2 (in Windows 8), and received the error "Open Failed: Error opening feature class" and "Warning: Could not add the specified data object to the map." Shapefiles stored in other locations load with no issues. Normally, I would assume that this was some sort of corruption of the shapefiles, but the modified dates on all of the files are listed as about a year ago, and even the shapefiles in this directory that I haven't opened in a year are affected.

 

I've tried the shapefile repair tool (Shapefile Repair Tool) and it throws an error stating that the file is in use by some other program. But I restarted and opened no GIS software, and then ran Unlocker (UNLOCKER 1.9.2 BY CEDRICK 'NITCH' COLLOMB) on the file, and it still gives the same error. I'm not able to open the files in QGIS either. I also tried copying the whole directory to a new location, and that did nothing to help.

 

Has anyone else experienced this? Can anyone suggest anything else to try here? Thanks!

Outcomes