AnsweredAssumed Answered

ArcObjects exe does not run as a scheduled task

Question asked by bveldkamp on Oct 31, 2014

Hi,

 

I have a .NET application using ArcObjects. It runs fine from the desktop, but fails to start when run as a scheduled task. The error it gives is: Failed to bind to an ArcGIS Server runtime. Ensure that the specified runtime is installed before running this application or Unable to initialize an ArcGIS 10.2 license. Could not find any of the following product license(s): Engine, Basic, Standard, Advanced

I found some other threads regarding this issue, but none of the answers solved my problem.

 

I already tried:

  • To set the task to run with highest privileges
  • Run the task as users SYSTEM, NETWORK SERVICE, Arcgis (i.e. the arcgis server account), and a newly added user (both with and without membership of Administrators group). All users give the same error.
  • Tried to see if the new user can actually start ArcMap: it can.
  • Explicitely bind to ProductCode.Server, or to ProductCode.DesktopOrEngine. No difference

 

My system is:

  • Windows Server 2008 RC2
  • ArcGIS Server Enterprise 10.2.2
  • ArcGIS Desktop 10.2.2 with Single use ArcEditor license

Outcomes