AnsweredAssumed Answered

Can't register file geodatabase with ArcGIS Server 10.2

Question asked by lwm on Oct 2, 2014
Latest reply on Oct 7, 2014 by lwm

Hi ArcGIS Server experts and users,

 

I run into the following issue in my first time of using ArcGIS Server 10.2 and any input from you is highly appreciated. I recently set up an ArcGIS server 10.2 and I am trying to publish services to it the first time. I am able to publish map service without problem but while I was trying to publish a file geodatabase as Geodata Service from a local desktop computer (Publisher) to the arcgis server,  I run into the following error.  

00133: Geodatabase is not registered with the server

 

I have done the following steps:

 

1. Both of the publisher (window 7) and the server (Windows Server 2012 R2) are under the same win domain and I use the same user name and password to access them.

2. There are two folders under the same name were created in local drive of the publisher and the arcgis server separately. Both of them are shared so that the server can access the local folder in the publisher.

3. I have registered the two folders in arcgis server manager and I can see the folder under data source.

4. I have a file geodatabase in the registered folder and I would like to publish it to the server as Geodata service. I then run into the above-mentioned problem.

5. I also try to manually copy the geodatabase to the folder in the arcgis server but it is still not working.

6. I am able though to publish a map service saved in the same folder as the file geodatabase to the server and did not run into the registration problem, which tells that the folders are registered.

 

My question is, why the geodatabase is not registered? According to ArcGIS help, any file geodatabase should be registered if the folder containing it is registered. Am I missing any critical steps? Thank you very much!

 

W.Li

Outcomes