AnsweredAssumed Answered

HTTPS and applyEdits

Question asked by koder303 on Oct 1, 2014
Latest reply on Oct 7, 2014 by koder303

Hello,

 

I recently implemented HTTPS on my whole site and converted my ArcGIS Server to HTTPS Only. Having solved a few problems, I am now able to see my secured services on my map. My secured services include dynamic services and feature services which I use for map tips.

 

A new problem I found however is using the applyEdits function on a feature layer. When I am in IE 9 and try to use applyEdits it says Access Is Denied even though the exact same approach worked for non-HTTPS.

 

If my url was http://a.b.com/arcgis/.../FeatureServer/1 I was able to use applyEdits

Now that my url is https://a.b.com:6443/arcgis/.../FeatureServer/1 my applyEdits throws an Access Is Denied error.

 

I should note that I create a new feature layer on the fly which I use for applyEdits but I do wait for its on('load') event to fire before I do anything with it.

 

I modified the proxy and I said before, I am able to get the feature layers when they are initially being loaded for map tips functionality. I inspected my call to the server when I run applyEdits and I see that https://a.b.com:6443/arcgis/.../FeatureServer/1 is going through a proxy.

 

Any suggestions or ideas on the new issue?

 

Thank you.

Outcomes