AnsweredAssumed Answered

Diagnosing replication problems?

Question asked by ameskamp on Sep 22, 2014
Latest reply on Sep 29, 2014 by ameskamp



I'm trying to create a 1-way replica into a FileGDB from an Oracle Enterprise SDE and keep hitting rather unspecific error messages. Here are some details:

  • Client: ArcGIS Desktop 10.0 SP5 with QIP on WS 2008 R2 and ArcGIS Desktop 10.2.1 with Update 1 on Windows 8 64 bit.
  • Database: ArcSDE 10.0 SP5 on Oracle on WS 2008 R2, using direct connect.
  • Database contents: 4 feature datasets with some geometric networks, a handful of relationship classes and some object tables, no class extensions. Almost all tables and feature classes are empty, except for one feature class that has around 4 million rows (building footprints, no network involved).
  • I've tried to make sure that all feature classes and tables are versioned, all have global IDs, database connection for replication is database owner.


I'm using python script that basically creates an empty FileGDB and then creates a replica using CreateReplica_management. The script is OK since I've managed to create one or two replicas with it.


Now, the test environment is a bit of a moving target, and frequently, I run into errors. Typical problems include class extensions, non-versioned feature classes, unexpected locks, missing global IDs, geometry problems in network data. I basically know how to locate and fix those issues, my problem is that I don't know which one it is this time, and checking everything is a lot of work. A typical error message looks like this:


arcgisscripting.ExecuteError: ERROR 000582: Error occurred during execution.

Failed to execute (CreateReplica).


It's a bit too early for a ReplicaLog.dat, there is no Build.txt, documentation for 582 basically says: "An error occurred". I had hoped that 10.2.1 would provide  a bit more information on replication problems than 10.0, but if it does, I haven't come across the information. Does anyone have suggestions on where to look for details of what happened?


Thanks, Martin