AnsweredAssumed Answered

Warning, inconsistent extent!

Question asked by cmdc3443 on Sep 17, 2014
Latest reply on Sep 17, 2014 by cmdc3443

 

           A couple of weeks ago, I received a paper that identified beaver complexes in the Gallatin County, MT in 1937.  Since I wanted to be able to use that information in my current project, I digitized the location by hand by creating a new feature class and drawing polygons while in an editing session.  I thought I defined a projection when I created the feature class but based on what has happened, I guess didn’t.  For the first day, everything worked well.  The only thing I noticed was that the attribute table didn’t have any spatial information.  This is what the table looked like minus all the records.

 

FID

Shape*

Id

App_Num_Dam

0

Polygon

23

4

1

Polygon

24

5

 

 

          Since the layer was projecting, I wasn’t worried about the lack of spatial data in the table until I tried to send the layer to a colleague. The next day she informed me that she couldn’t view the layer because I didn’t send a .prj accessory file.  After discovering there was no .prj file, I thought I could easily fix the problem using the Define Projection tool in ArcMap.  I first tried projecting it with the Lambert Conformal Conic projection and the layer showed up in northern Australia. Since I am in southwest Montana, this was definitely incorrect.  I tried re-projecting the layer again using GCS_North American_NAD 83 and this time it didn’t show up at all when I tried to “Zoom to Layer”.

 

        I took my little problem to my boss who, when she pulled the layer onto the map she was working, was able to see it in the middle of the Altantic Ocean.  After she re-projected the layer, it disappeared.   After much zooming out, we discovered that the layer had left the planet.

 

          We found this article on the esri website http://support.esri.com/en/knowledgebase/techarticles/detail/29129  and followed the given instructions.   The extent box in the source tab gave the following coordinates: Top: 5692402.        Right: -12368816.       Bottom: 5619181.        Left: -12406878.     With this information, we deduced that when the layer is projected in a Projection Coordinated System such as Lambert Conformal Conic the layer shows up in space because of the large negative Left and Right values and when projected in a Geographic Coordinate System such as GCS_North American_NAD 83 it can’t project because the extent values are larger than 3 digits.  This is consistent with the alert that pops up every time I try to add the layer to a new map:

                         Warning, inconsistent extent!

One or more of the added layers has an extent that is not consistent with the associated spatial reference information.

Re-projecting the data in such a layer may lead to unexpected behavior.

 

My question for you is: since it was working at the beginning, shouldn't there a way to get it back?  I’d even be happy to get it back to northern Australia!  I should be able to get it back to what it was, shouldn’t I?  All I’ve done the layer is re-project multiple times.  Has anyone have had a similar problem?

 

 

 

Outcomes