AnsweredAssumed Answered

Printing Issue

Question asked by tauhirm on Sep 16, 2014

I keep getting an HTTP 400 error when trying to use the printing widget with my own printing service as well as the ArcGIS printing utility with my application and have no clue why.

 

Using:

IIS7

ArcGIS Server 10.1

 

However, when hosting my application locally I am able to use only the standard ArcGIS printing utility.

 

The server logs look like this:

Level

Time

Message

SEVERE

Sep 10, 2014 2:06:35 PM

Error executing tool.: Layer "World_Imagery_6391": Unable to connect to map server at http://services.arcgisonline.com/ArcGIS/rest/services/World_Imagery/MapServer. Layer "GCRO_adminstrative_base_layers_935": Unable to connect to map server at http://gcro3.wits.ac.za/arcgis/rest/services/GCRO_GIS_Website/GCRO_adminstrative_base_layers/MapServer. Failed to execute (Export Web Map). Failed to execute (Export Web Map Task).

SEVERE

Sep 10, 2014 1:35:50 PM

Error executing tool.: Layer "World_Imagery_6391": Unable to connect to map server at http://services.arcgisonline.com/ArcGIS/rest/services/World_Imagery/MapServer. Failed to execute (Export Web Map). Failed to execute (Export Web Map Task).

 

I have done the following to try and resolve the errors:

     -Made sure the printing service was switched on

     -Made sure I could browse to the service in the REST directory

     -Gave internet access permissions to the local ArcGIS account

 

Much needed help will be appreciated

Outcomes