AnsweredAssumed Answered

Cannot Install on Windows 8 Possibly due to .NET Framework

Question asked by rhansman on Aug 23, 2013
Latest reply on Aug 24, 2013 by rhansman
Hello,

I am running an HP desktop with a preinstalled Windows 8 64bit, and am getting this error when installing ArcGIS Desktop 10.1 (I am turning off all programs and disabling Avast Antivirus).

Error 1935. An error occurred during the installation of assembly 'Microsoft.MSXML2,processorArchitecture="x86",publicKeyToken="6bd6b9abf345378f",version="4.20.9818.0",type="win32'".

I followed the instructions here to add RegistrySizeLimit:
http://forums.arcgis.com/threads/21056-AcrGIS-won-t-install

That made no difference, and from what I was reading it seems like the .NET Framework 3.5 SP1 needs to be installed. I went to 'Windows Features', but there is no check box to select the .NET Framework, see image:

[ATTACH=CONFIG]26922[/ATTACH]

I tried selecting 'Application Development Features', but get the error:

The system has attempted to load or restore a file into the registry but the specified file is not in a registry file format.
Error code: 0x800703F9


So then I download the .NET Framework 3.5 exe (dotnetfx35setup) from:
http://www.microsoft.com/en-us/download/details.aspx?id=22

I run it in admin mode, and click yes to allow it to make changes to my computer, then absolutely nothing happens. I also try the same with the 3.5 standalone installer.

I then try using a Windows 8 bootable DVD and using the Dism cmd. As mentioned in this link:
http://support.esri.com/en/knowledgebase/techarticles/detail/41097

This gives me another error as shown in the image:

[ATTACH=CONFIG]26923[/ATTACH]

Here is the dism log: [ATTACH=CONFIG]26925[/ATTACH] and [ATTACH=CONFIG]26926[/ATTACH] (part 3 can be added if needed, maxed out attachment limit)

I ran the .NET Framework setup verification tool from here:
http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

I used it to verify .NET Framework 3.5 SP1 and this is the output:

[ATTACH=CONFIG]26924[/ATTACH]

So now I really don't know what to try next.
Thanks for any help.

Regards,
Reuben

Outcomes